Warning: call_user_func_array() expects parameter 1 to be a valid callback, class 'collapsArch' does not have a method 'enqueue_scripts' in /home/customer/www/allanhutchison.net/public_html/wp-includes/class-wp-hook.php on line 307

Force Add-on Compatibility Firefox 4.2a1pre

For those on the Firefox 4 nightly builds the next update appears to be Firefox 4.2a1pre. Now I have no idea how they came up with this numbering as I thought Mozilla was going to be moving on to Firefox 5 next. Of course, Mozilla is known for changing numbering mid-way through development. Firefox 3.1 became Firefox 3.5 and Firefox 3.7 (though never officially labeled) became Firefox 4.

While Nightly Tester Tools does work with this new version, the Force Add-on Compatibility feature is not. The good news is it appears the add-ons which are working with Firefox 4 will work with this new developmental version. However, you will have to manually disabled add-on compatibility checking:

  1. In a new tab type about:config in the address bar and press enter
  2. Click the I’ll Be Careful, I Promise button (if applicable)
  3. Right-click on any of the entries and select New, then Boolean
  4. There are 3 preferences you will need to create and set all to False :
    • extensions.checkCompatibility.4.2a
    • extensions.checkCompatibility.4.2a1
    • extensions.checkCompatibility.4.2a1pre
  5. Close and restart Minefield and your extensions should be enabled again.

 

5 Comments on Force Add-on Compatibility Firefox 4.2a1pre

  1. Works like a magic!! Will it cause any issues?

  2. thanks !hope it work for me !

  3. What’s wrong with just using the Add-on Compatibility Reporter ?

    • Wow. That’s way better than all the other workarounds posted everywhere. I’m not sure why that doesn’t come default for early releases. Thanks for mentioning it!

    • Never had tried that add-on but now it looks like the about:config method did not work correctly in the Firefox 7 Nightly builds.

1 Trackbacks & Pingbacks

  1. More About Firefox 4.2a1pre | Firefox Extension Guru's Blog

Comments are closed.