Warning: call_user_func_array() expects parameter 1 to be a valid callback, class 'collapsArch' does not have a method 'enqueue_scripts' in /home/customer/www/allanhutchison.net/public_html/wp-includes/class-wp-hook.php on line 307

Firefox 2.0.0.8 Released

The latest and greatest update on the Firefox 2.0 branch has been released. This update fixes eight security vulnerabilities including two labeled critical, along with other 100+ stability and performance patches. Users should be getting an auto-update prompt in the next 24-48 hours or can manually update now via Help, Check for Updates…

Firefox 2.0.0.8 Release Notes

As a reminder if you are still using Firefox 1.5, Mozilla has ceased support and updates nearly six months ago. Users are strongly encouraged to upgrade to the latest Firefox 2 build. Mac users, there are some known Firefox issues on Leopard.

News Sources: